Print view · Advanced Operations · 50 pagesChoose "Save as PDF" as the destination in the print dialog.
Back to the docs

Mesh Morpher documentation

Advanced Operations

50 pages · exported 2026-09-06 · https://meshmorpher.com/docs/classic/editor/advanced-operations

Classic › Editor

Advanced Operations

Classic › Editor › Advanced Operations

Create from Mesh

Mesh Morpher allows users to create a Morph Target from another Mesh, thus providing the ability to morph objects/face/bodies into other Skeletal Meshes.

In order for this functionality to work correctly, meshes need to share same vertex count and order.

Mesh Morpher goes even further by checking for the same vertex count and order on any of the available LODs, and if found, will grab the deltas and project them on LOD0(and then the LOD0 projected result will be re-projected on all other LODs).

There are two ways to create Morph Targets from Mesh:

  • By clicking Create from Mesh in Mesh Morpher's toolbar
  • Navigating to Tools top dropdown menu and clicking Create from Mesh

Once the Create from Mesh button is pressed, a dialog box will open where users can select several options.

Options Description
Source The Skeletal Mesh to create the Morph Target from.
New Morph Name Users can also pick the Morph Target name that will be created.
Threshold Maximum Distance threshold between a vertex in the target mesh and a vertex in source mesh, at which they are considered to be correspondent. Used only by Projection.
Normal Incompatibility Threshold Normal threshold at which a triangle is deemed as incompatible. This helps to avoid triangle flipping during Projection.
Smooth Iterations Smooth Iterations steps used to Smooth the resulted Projected Deltas.
Smooth Strength Smooth Strength used to Smooth the resulted Projected Deltas.
Smooth Type Smooth Type used to Smooth the resulted Projected Deltas.

For Meta Human faces, in order to have the best result, in MHC, select same body, eyelashes, eyebrows and hair in order to maximize the possibility to have same vertex count and order on LOD0.

Result

If successful, a dialog box will pop, notifying users whether the operation was successful.

If the Morph Target name is already in use, a new dialog box will pop asking whether to overwrite or change the name. Pressing Yes will clear and overwrite the existing Morph Target.

Keyboard shortcut: Ctrl + Shift + I

The button is greyed out when there's no skeletal mesh loaded

Classic › Editor › Advanced Operations

Create from Mesh Files

Mesh Morpher allows users to create a Morph Target from another Mesh Files and it supports both FBX/OBJ formats.

In order to create Morph Targets from Mesh Files, Mesh Morpher requires two file inputs (Base and Morphed), from which it grabs the deltas. Those deltas are then projected on the Skeletal Mesh.

In order for this functionality to work correctly, both Mesh Files (Base and Morphed) need to share same vertex count and order.

Enabling UV Matching allows users to overcome this limitation.

There are two ways to create Morph Targets from Mesh Files:

  • By clicking Create from Mesh Files in Mesh Morpher's toolbar
  • Navigating to Tools top dropdown menu and clicking Create from Mesh Files

Create from Mesh Files supports both triangulated and quads meshes with the condition that both files have same vertex count and order.

It is recommended that if users want to work with quads, to convert the base file to quads(Blender or any other DCC) and then they duplicate the quad base file(name it Morphed) and they do the work on the duplicate file.

In Blender this is how to convert triangle meshes to quads.

Mesh Morpher exports and imports Mesh Files with X as Forward Axis and Y as Up Axis, therefor imports and exports in third-party DCC files should use the same settings.

In order for the Morph Target to be successfully created, all 3 meshes (Base, Morphed and Skeletal Mesh) should face same direction. This can be always achieved by changing the axes or transforms of the input files.

Mesh OBJ Files have been imported using X as Front and Y UP in blender and exported using the same.

Result

Mesh Morpher doesn't require for Base file to be identical with the Skeletal Mesh, but the more they resemble the better the output result.

Threshold is what controls how permissive Mesh Morpher is when the projection is happening. Higher Threshold means that Mesh Morpher is more permissive with the differences between Base and Skeletal Mesh. With a very low Threshold(for example 0.001) users are hinting that only very similar vertices would be part of the final result.

Mesh Morpher will throw errors when something goes wrong:

  • Morph Target: %s has no valid data. Base Mesh and Morphed Mesh are the same or did not generate any deltas. This error is self explanatory, when the Base and Morphed files are the same, there are no deltas to project.
  • Morph Target: %s has no valid data. Base Mesh and Skeletal Mesh have no similarities? This error could happen for various reasons, either the base mesh is too different from the skeletal mesh, or it doesn't face the same direction as the skeletal mesh.

Default settings are what works in most tests and experiments. Users are supposed to tweak and customize the settings based on their inputs.

Create from Mesh Files and CC4 in Mesh Morpher

If successful, a dialog box will pop, notifying users whether the operation was successful.

If the Morph Target name is already in use, a new dialog box will pop asking whether to overwrite or change the name. Pressing Yes will clear and overwrite the existing Morph Target.

Keyboard shortcut: Ctrl + Shift + F

The button is greyed out when there's no skeletal mesh loaded

Classic › Editor › Advanced Operations › Create from Mesh Files

General

Option Description
Automatically Overwrite If selected, Morph Targets on target Skeletal Mesh will automatically be overwritten without asking.
Bulk Import Whether to enable or disable bulk import. Enabling this option will switch Morphed File to Morphed Directory and vice-versa
Prefix String to prefix morph targets names on bulk import (appears when Bulk Import enabled)
Suffix String to append to morph targets names on bulk import (appears when Bulk Import enabled)

Other settings:

Option Description
New Morph Name Target Morph Name. If it exists you can overwrite. (appears only with Bulk Import disabled)
Render Meshes Whether files are rendered in the scene

Classic › Editor › Advanced Operations › Create from Mesh Files

Base

Options Description
Base File Original/Unchanged Mesh File
Base Use T0 Pose Enable this option to use frame 0 as reference pose. This works only for FBX files. Useful for imports from CC3/CC4
Base Coordinate System Coordinate System used to import the file. Supports both left and right.
Base Front Axis The default Front axis in Unreal Engine(Y)
Base Up Axis The default UP axis in Unreal Engine(Z)
Base Transform Offset the mesh file. Allows location, rotation and scale.

Classic › Editor › Advanced Operations › Create from Mesh Files

Morphed

Options Description
Morphed File Modified version of Base File (appears with Bulk Import disabled)
Morphed Directory Directory containing multiple modified versions of Base File (appears with Bulk Import enabled)
Morphed Use T0 Pose Enable this option to use frame 0 as reference pose. This works only for FBX files. Useful for imports from CC3/CC4
Morphed Coordinate System Coordinate System used to import the file. Supports both left and right.
Morphed Front Axis The default Front axis in Unreal Engine(Y)
Morphed Up Axis The default UP axis in Unreal Engine(Z)
Morphed Transform Offset the mesh file. Allows location, rotation and scale.
Lock Transform If enabled, Morphed inputs use same transform as Base mesh.

Classic › Editor › Advanced Operations › Create from Mesh Files

Options

Option Description
Threshold Maximum Distance threshold between a vertex in the target mesh and a vertex in source mesh, at which they are considered to be correspondent.
Normal Incompatibility Threshold Normal threshold at which a triangle is deemed as incompatible. This helps to avoid triangle flipping during Projection.
Match Material IDs Apply deltas only to vertices that have same material ID. The material ID is checked between skeletal mesh and base file. This requires both to have same material count and order.
Subdivision Subdivide the input files. This usually increase quality and the precision of the final resulted Morph Target if topology is drastically changed in base file

Classic › Editor › Advanced Operations › Create from Mesh Files

UV Match

Option Description
Match By UV

!!Experimental!!

Match Base and Morphed files by UVs, ignoring vertex count and order.

This shouldn't be used with welded meshes because they don't have their UVs intact.

Match UV Iterations Match UV iterations. Vertices without a matching UV correspondent are reiterated for the amount of iterations and assigned neighbor found matches.

Classic › Editor › Advanced Operations › Create from Mesh Files

Smoothing

Option Description
Smooth Iterations Smooth Iterations steps used to Smooth the resulted Projected Deltas.
Smooth Strength Smooth Strength used to Smooth the resulted Projected Deltas.
Smooth Type Smooth Type used to Smooth the resulted Projected Deltas.

Classic › Editor › Advanced Operations

Poser

Mesh Morpher allows users to create Morph Targets from Poses.

Mesh Morpher allows users to create Morph Targets from Poses.
Poses can be an Animation frame, a Bone Snapshot or a combination of an Animation frame and Bones modification.

There are two ways to create Morph Targets from Pose:

  • By clicking Create from Pose in Mesh Morpher's toolbar
  • Navigating to Tools top dropdown menu and clicking Create from Pose

Once the Create from Pose button is pressed, a dialog box will open where users can select several options.

Options Description
Animation Blueprint Allows users to select and enable an Animation Blueprint in Poser
Disable Post Process Blueprint

Toggles the Post Process blueprint in the selected skeletal mesh in Poser

Disable Cloth Simulation

Toggles the cloth simulation for the selected skeletal mesh in Poser

Enable CCD Toggles Continuous Collision Detection in Poser
Reference Mesh Allows users to select a skeletal mesh as a reference
Enable Master Pose Set the Leader/Master Pose Component for the reference mesh to the main skeletal mesh opened in Poser
New Morph Name Users can also pick the Morph Target name that will be created.

Classic › Editor › Advanced Operations › Poser

Bake Skeleton

Bake Skeleton allows users to permanently bake skeleton and mesh changes in Poser to the Skeletal Mesh and Skeleton.

Option Description
Bake to Skeletal Mesh Reference Skeleton This option enables the skeleton changes to be baked in the Skeleton Reference which is located inside the Skeletal Mesh.
Bake Mesh Data This option allows to bake Mesh data to skeletal Mesh. Required to reflect skeleton changes in the mesh data.
Bake To DNA Asset Bakes skeleton and Mesh data to the DNA Asset if available. This is intended for Meta Humans only. It doesn't bake any Morph Target data.
Remove Scaling This scales back to 1,1,1 all bones while preserving translations and rotation. Useful for FBX exports.
Orient Bones List of bones to recompute orientations for. To disable, simply remove the bones from the list. This impacts how Pose Drivers and control Rigs functions(for metahumans as well)
Orient Bones Above Bone Recomputes the orientations for all the bones above the selected bone name in the hierarchy. To disable, simply set the bone name to None. This impacts how Pose Drivers and control Rigs functions(for metahumans as well)
Create Skeletal Mesh Backup Whether to create a backup before baking. Users will be prompted to save the asset. The asset will have "_bk" suffix automatically added.

Classic › Editor › Advanced Operations › Poser

Create Reverse Morph Target

This option allows users to create a reversed Morph Target from the current Pose. 

By default the Morph Targets contain the deltas between the default Skeletal Mesh and the modified Skeletal Mesh.

By creating a Reverse Morph Target, the Morph Target will hold the deltas between the Modified Skeletal Mesh and the default Skeletal Mesh.

If the Toolkit(Main Window) has a Pose asset selected or there is a Base Pose selected in Poser then this Morph Target will be a reversed corrective Morph Target between those two poses.

Classic › Editor › Advanced Operations › Poser

Create Morph Target

This option allows users to create a Morph Target from the current Pose. 

By creating a Morph Target, the Morph Target will hold the deltas between the default Skeletal Mesh and the modified Skeletal Mesh(Poser pose).

If the Toolkit(Main Window) has a Pose asset selected or there is a Base Pose selected in Poser then this Morph Target will be a reversed corrective Morph Target between those two poses.

Classic › Editor › Advanced Operations › Poser

Animation Curves

Poser allows users to interact with Animation Curves.

Animation curves can be enabled and disabled and also exported to OBJ files or converted to Morph Targets.

Classic › Editor › Advanced Operations › Poser › Animation Curves

To Morph Targets

Animation Curves can be converted to Morph Targets.

To do so, select the animation curves and click on To Morph Targets.

A new dialog will open.

In this new dialog users can select a prefix and suffix for the new Morph Targets names.

Classic › Editor › Advanced Operations › Poser › Animation Curves

To OBJ Files

Animation Curves can be exported to OBJ files.

To do so, select the animation curves and click on To OBJ Files or right click the list and select the same.

A new dialog will open.

In this dialog window, users will be able to select a prefix and suffix for the OBJ files, append additional meshes and also weld the OBJ file.

Classic › Editor › Advanced Operations › Poser

Morph Targets

Poser allows users to interact with Morph Targets.

Morph Targets can be enabled and disabled and also exported to OBJ files.

Classic › Editor › Advanced Operations › Poser › Morph Targets

To Bonesnapshot

Bone Snapshots can be created from Morph Targets which allows users to fit the skeleton to match the Morph Target shape.

In order to do so, select a Morph Target and click on To Bonesnapshot.

A dialog window will open.

Option Description
Start Bone Pick the first bone in the Bonesnapshot. Users can select whether to bonesnapshot will start from root or any other bone in the skeleton hierarchy
End Bone The end Bone in the hierarchy that will be part of the bonesnapshot
Include Reference Mesh Whether to include the selected reference skeletal mesh in the bonesnapshot. This option appears only when a reference skeletal mesh is selected in Poser and a Morph Target with the same name exists on both meshes.
Ignore Bones List of Bones to ignore. One per row. Ignored bones will not be part of the bonesnapshot
Ignore String Ignore all bones containing the string. Ignored bones will not be part of the bonesnapshot
Orient Bones List of bones to recompute orientations for. To disable, simply remove the bones from the list. This impacts how Pose Drivers and control Rigs functions(for metahumans as well)
Orient Bones Above Bone Recomputes the orientations for all the bones above the selected bone name in the hierarchy. To disable, simply set the bone name to None. This impacts how Pose Drivers and control Rigs functions(for metahumans as well)
Save Changed Bones Only Whether the bonesnapshot will hold only the bones that have their transform changed during the fitting.
Advanced Fitting Enable this when fitting bones to morph targets for meta human expressions.
Bone to Vertex Threshold Maximum distance at which a bone is deemed to be compatible with a vertex.
Bone to Bone Threshold Maximum distance at which a bone is deemed to be compatible with another bone.
Max Distance To Surface Maximum distance to surface
Use Vertex Weights Whether to use vertex weights when available
Preserve Relative Bone Transforms Whether to preserve relative bone transformations.
Vertex Sample Size Nearest Vertex Sample Size used to reposition the bones.
Advanced Bone Fitting

Advanced Bone Fitting is using Dem Bones and its purpose solely intended to create bonesnapshots from facial expressions morph targets.

Copyright (C) 2019 Electronic Arts Inc. All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

  1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
  2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.
  3. Neither the name of Electronic Arts, Inc. ("EA") nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY ELECTRONIC ARTS AND ITS CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL ELECTRONIC ARTS OR ITS CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

Classic › Editor › Advanced Operations › Poser › Morph Targets

Update from Pose

Morph Targets can be updated from the current Pose in Poser.

This means that if the bones changed, by Updating from Pose the deltas in Morph Target will only contain the deltas between the Pose in Poser and the final Morph Target shape.

Classic › Editor › Advanced Operations › Poser › Morph Targets

To OBJ Files

Morph Targets can be exported to OBJ files from Poser

To do so, select the Morph Target and click on To OBJ Files or right click the list and select the same.

A new dialog window will open.

In this dialog window, users will be able to select a prefix and suffix for the OBJ files, append additional meshes and also weld the OBJ file.

Classic › Editor › Advanced Operations › Poser

Correctives

The Poser allows users to create corrective Morph Targets. 

Corrective Morph Targets hold deltas between Base Pose and Current Pose.

In order to set a Base Pose users have to navigate to Tools menu and select Set Current Pose as Base.

To reset the Base Pose select Clear Base Pose.

Clicking on Create Morph Target or Create Reverse Morph Target will create the corrective Morph Target.

Classic › Editor › Advanced Operations › Poser

Bone Editor

Bone Editor in Poser allows users to modify bone transforms and pivots.

Bone Editor allows Symmetry and a lot of additional customization that can improve the experience.

Holding Left Ctrl while clicking a bone will toggle its selection status. Users can select multiple bones at once.

Clicking on no bone will deselect all bones.

Bone editor supports Bone Symmetry and can be enabled by enabling the Symmetry Checkbox

Bonesnapshots are another important component of Bone Editor and users are allowed to Load and Save Bonesnapshots that will hold the skeleton transformation.

Classic › Editor › Advanced Operations › Poser › Bone Editor

Symmetry

The Poser in Mesh Morpher allows users to have transform symmetric bones.

Options Description
Use Symmetric Bones Whether to enable or disable bone Symmetry
Mirror Rotation Whether transforming a symmetric bone uses symmetric rotation
Symmetry Axis Symmetry axis used for symmetric bone transformation

Classic › Editor › Advanced Operations › Poser › Bone Editor

Pivot

The Poser in Mesh Morpher allows Pivot editing.

Options Description
Enable Pivot Editor Enabling Pivot Editor allows users to transform bones without affecting Mesh Data. Disabling the Pivot Editor will bake the changes to the skeletal mesh.
Update Children Whether changing the transform of a Pivot Bone updates its children bones.

Classic › Editor › Advanced Operations › Poser › Bone Editor

Draw

Mesh Morpher allows users to customize the way bones are drawn in the viewport.

Options Descriptions
Draw Bones Whether to draw Bones in viewport
Draw Full Bones Whether to draw Full Bones in viewport
Bone Thickness Bone Indicator Thickness
Bone Indicator Size Bone Indicator Size
Scale Bone Indicator to Bone Size Whether to scale Bone Indicator based on the Bone size
Deselected Bone Color Color used to draw deselected bones
Selected Bone Color Color used to draw selected bones

Classic › Editor › Advanced Operations › Poser › Bone Editor

Bone Scale and Animation Retargeting

When working with Animation or control rigs(modular rigs as well) the engine in general doesn't play well with scaled bones.

To overcome this users should bake with Remove Scaling enabled

The above options works only for bones above root in the skeleton hierarchy.
For root bone(or any other bone) scaling can be removed manually.
After scaling, disable Update Children option in Bone Options side panel and set back the scale to 1.(don't forget to re-enable Update Children after you've completed this step).

Here's a video going through the process.

Classic › Editor › Advanced Operations › Poser › Bone Editor

Lock Bones

Lock the selected bones. Locked Bones always preserve their original transformation when using Transform Gizmo to edit skeleton.

Lock the selected bones. Locked Bones always preserve their original transformation when using Transform Gizmo to edit skeleton.

Classic › Editor › Advanced Operations › Poser › Bone Editor

Unlock Bones

Unlock the selected bones. Locked Bones now being unlocked can be edited using Transform Gizmo.

Unlock the selected bones. Locked Bones now being unlocked can be edited using Transform Gizmo.

Classic › Editor › Advanced Operations › Poser

Bone Snapshots

Bone snapshots are a snapshot of all bones in a skeletal mesh that hold the required data to be loaded at runtime or in editor.

Bonesnapshot menu

Options Description
Asset Picker Allows users to load a bonesnapshot or an animation sequence
Reset Resets the current pose to the Default neutral pose
Save Save a pose to the current bonesnapshot. If a bonesnapshot is not loaded it asks for a new bonesnapshot location
Save As... Save the current pose as a new bonesnapshot
Add Axis Rotation Manually add rotation in degrees on the selected axis. Allows users to rotate manually with increased precision
To Sequence.. Save current Pose as an animation sequence

Classic › Editor › Advanced Operations

Copy

Mesh Morpher allows users to copy/project Morph Targets from one Skeletal Mesh to other Skeletal Meshes.

Users can bulk-copy Morph Targets to multiple Target Skeletal Meshes at once.

Mesh Morpher checks if the source and target skeletal meshes are identical(vertex count, Positions and Normals).
If the Skeletal Meshes are identical then Mesh Morpher proceeds with simply transferring the Morph Targets from Source to Target.
If the Skeletal Meshes are not identical then Mesh Morpher will attempt to project the Morph Targets on the Target Skeletal Meshes using the given parameters.

The quality of the resulted projection is directly proportional with the resemblance and similarity between the Source and Target. The more the meshes look alike, the better the projected result will be.

You can Copy a single Morph Target or multiple Morph Targets by using Ctrl+Click or Shift+Click to select additional Morph Targets in the Morph Targets list.

There are three ways to Copy Morph Targets:

  • By clicking Copy in Mesh Morpher's toolbar
  • By Right-clicking on the Morph Target you want to copy in Morph Targets list and select Copy.
  • Navigating to Tools top dropdown menu and clicking Copy

Once the Copy button is pressed, a dialog box will open where users can select several options.

Users can add and remove multiple Targets by clicking the + sign in the Targets field

Users can remove items from the Targets list by the symbol as in the bellow image and select Delete.

Options Description
New Morph Name This parameter will become visible if only one Morph Target is selected for copying. This is the Morph Target Name on the Target Skeletal Mesh where Mesh Morpher will copy.
Automatically Overwrite

This option will allow users to automatically overwrite Morph Targets on the Target Skeletal Mesh if they already exist. Otherwise, if this option is disabled and a Morph Target with the same name exists on the Target Skeletal Mesh, users will be asked if they want to overwrite.

Selecting No will skip to the next Morph Target to copy, if any.

Threshold Maximum Distance threshold between a vertex in the target mesh and a vertex in source mesh, at which they are considered to be correspondent. Used only by Projection.
Normal Incompatibility Threshold Normal threshold at which a triangle is deemed as incompatible. This helps to avoid triangle flipping during Projection.
Smooth Iterations Smooth Iterations steps used to Smooth the resulted Projected Deltas.
Smooth Strength Smooth Strength used to Smooth the resulted Projected Deltas.
Smooth Type Smooth Type used to Smooth the resulted Projected Deltas.

For single Morph Target copy/projection, if there is any generated result, a dialog box will pop, notifying users whether the operation was successful. For multiple selection this dialog will not show.

Keyboard shortcut: Ctrl + C

The button is greyed out when there's no selection.

Copy allows single and multi-selection.

Morph Target copying is irreversible.

Classic › Editor › Advanced Operations › Wrapper

Options

here are several options that allow users to interact with the Wrapper and pre-configure it.

Source

OptionDescription
SourceMeshAllows users to select the Source Mesh. Source Mesh is the mesh we want to take the shape from using the wrapper.
SourcePoseAllows users to set a pose from an animation sequence asset.
SourcePoseFrameAllows users to select a frame from the pose animation sequence
bHideSourcePreviewMeshWhether to hide the Source preview mesh component
bHideSourceReferenceMeshWhether to hide the Source reference mesh component

Target

OptionDescription
TargetPoseAllows users to set a pose from an animation sequence asset.
TargetPoseFrameAllows users to select a frame from the pose animation sequence
bHideTargetPreviewMeshWhether to hide the Source preview mesh component
bHideTargetReferenceMeshWhether to hide the Source reference mesh component

Options

OptionDescription
NewMorphNameTarget Morph Name. If it exists you can overwrite.

View

OptionDescription
bLockCamerasWhether to lock the cameras to same transform in both viewports. Works only when both viewports have the same view types.

Classic › Editor › Advanced Operations › Wrapper

Wrapper Settings

The Wrapper has various options that allow users to customize how the wrapping performs and influence its results.

General

OptionDescription
KNNNumber of closest points when looking for correspondents on the opposite surface.
AffinityThresholdAffinity values higher than this make flag values 1 (all others 0).
bNormaliseAffinityAllow vertex affinities to be normalized independently to negate distance bias.
VertexRangeRange for discovering correspondences
bUseOrientationWhether or not to use Vertex Normals when evaluating correspondences.

Iterations

OptionDescription
IterationsNumber of iterations. Higher count often provides better results.
StickyIterationsWeight Smoothing Sticky Iterations. Higher value means less impact as the vertices are moving together.
ElasticIterationsWeight Smoothing Elastic Iterations. Higher value means less impact as the vertices are moving together.

Smoothing

OptionDescription
SmoothNeighboursNumber of neighbors in local smoothing region for each vertex.
SmoothGaussianWidthSmoothing Gaussian Width.

Resolution

OptionDescription
SourceResolutionResolution subdivision for source mesh.
TargetResolutionResolution subdivision for target mesh.
bForceFitForce fitting attempts a final fit of the wrap result to the source mesh. This requires a higher source resolution for better results.

Control Points

OptionDescription
ControlPointInfluenceControl Point Influence Radius.
ControlPointNormalThresholdWhether or not the Control Points can find in their radius only un-flipped triangles.

Classic › Editor › Advanced Operations › Wrapper

Control Points

Control Points are used to hint the geometry to the non-rigid fitting algorithm.

Control Points are used to hint the geometry to the non-rigid fitting algorithm.
Users can add as many Control Points they want and can overlap them without any issue.

Control points need to have same count and order in both target and source meshes as they`re used to hint correspondent landmarks between the two of them to the non-rigid fitting algorithm.

There are several options that allow users to configure how control points work in Mesh Morpher's wrapper.

In order to add/remove Control Points, users have to select Control Points in Advanced Menu.

Users can Save, Load, Clear and change the Influence of the Control Points for both Target and Source.

To select a Control Point, users can Left Click on it which also allows them to change the influence for the selected Control Point

Reset Influence resets the Influences for all Control Points to the value located in Wrapper Settings.

Right Clicking on a Control Point will remove it and doing so will change the Index for the Control Points with a higher index.

Aligning bones, changing Section Selection or masking will clear out the selected Control Points.

Options Description
Control Point Influence The Influence of a Control Point determines the radius in which the control points gather mesh vertices and uses them to find correspondent vertices in its Pair.
ControlPointNormalThreshold Whether or not the Control Points can find in their radius only un-flipped triangles.

Holding Left Shift while adding a Control Point will create a Symmetric Control Point as well.

There are several visual settings for Control Points that can be access by navigating to Edit->Settings.

Options Description
ElementThickness The thickness used to display the debug sphere for Control Points
ControlPointSize The size of the displayed Control Point dot marker on the mesh
ControlPointFontColor Font Color of the Control Point Index Indicator
ControlPointFontShadowColor Font Shadow Color of the Control Point Index Indicator
bShowDebugControlPoints Whether to display the influence radius debug sphere for Control Points.

Classic › Editor › Advanced Operations › Wrapper

Bone Editor

The Bone Editor in the Wrapper allows users to match poses or set specific poses for both Target and Source.

In order to open Bone Editor, users have to select Bone Editor in Advanced Menu.

Selecting a bone in the Bone list or clicking on a bone in the viewport for both target and source will select the bone and display a Gizmo that allows to change rotation, translation and scale.

Users can also manually enter transformation values in the widgets below the bone list.

Bone Editor allows Undo/Redo actions by using Ctrl+Z and Ctrl+Y

Bone editor supports Bone Symmetry and can be enabled by enabling the Symmetry Checkbox

Bonesnapshots are another important component of Bone Editor and users are allowed to Load and Save Bonesnapshots that will hold the skeleton transformation.

There are several visual settings for Bone Editor that can be accessed by navigating to Edit->Settings.

bDrawBones Whether to draw bone indicators in the Target and Source Viewports
bDrawFullBones Whether to draw bone indicators from start to end in the Target and Source Viewports
BoneIndicatorSize The bone drawing indicator size
bScaleBoneIndicatorToBoneSize Whether to scale the bone indicator relative to the bone size
DeselectedBoneColor The color of the bone indicators when they're unselected
SelectedBoneColor The color of the bone indocators when they're selected

Classic › Editor › Advanced Operations › Wrapper

Section Selection

Section Selection in the Wrapper allows users to select certain mesh sections in both Target and Source. The wrapping will proceed only for the selected mesh data.

In order to open Section Selection, users have to select it in Advanced Menu.

Users can select multiple sections or deselect.

Classic › Editor › Advanced Operations › Wrapper

Masking

Classic › Editor › Advanced Operations

Bake

Mesh Morpher allows users to bake Morph Targets on the Skeletal Mesh.

Mesh Morpher allows users to bake Morph Targets on the Skeletal Mesh.
Baking writes the Morph Target deltas to the Skeletal Mesh Import data(if available) or LOD Model data.
Baking is persistent and permanent.

There are two ways to Bake Morph Targets:

  • By clicking Bake in Mesh Morpher's toolbar
  • Navigating to Tools top dropdown menu and clicking Bake

Once the Bake button is pressed, a dialog box will open where users can select which Morph Targets to Bake.

Mesh Morpher will attempt to bake the Morph Targets that have a weight different than 0.
After baking is completed the baked Morph Targets are removed from the Skeletal Mesh.

Users can select multiple Morph Targets with different weight from the list and in the preview viewport they can visualize how the final result will look like.

After the Morph Targets are baked. Mesh Morpher will also attempt to offset the existing Morph Targets in Import Data so they'll reflect the actual mesh.

Keyboard shortcut: Ctrl + B

The button is greyed out when there's no skeletal mesh loaded

Morph Target Baking is irreversible.

Classic › Editor › Advanced Operations

Recompute Normals

Recompute Normals allows users to recompute the Normals for a selection of skeletal meshes.

The Normals are computed in such way that there is no seam if multiple skeletal meshes are selected as the meshes are getting welded in the underlying algorithm and the normals are then projected back to the Skeletal Meshes.

Option Description
Skeletal Meshes Array of skeletal Meshes
Update DNA Asset Bakes Normals to DNA Asset Mesh Data if available. This is intended for Meta Humans only.
Merge Vertex Tolerance Edges are coincident if both pairs of endpoint vertices are closer than this distance
Merge Search Tolerance Edges are considered as potentially the same if their midpoints are within this distance. Due to floating-point roundoff this should be larger than MergeVertexTolerance.
Merge Only Unique Pairs Only merge unambiguous pairs that have unique duplicate-edge matches

Classic › Editor › Advanced Operations

Stitch

Mesh Morpher has the ability to stitch two morph targets between two meshes.

Option Description
Boundary Threshold Distance Threshold at which the boundary vertices are coincident
Use Edge Closest Point Whether the correspondent vertices are glued to the closest point on edges.
Vertex Threshold The Maximum Threshold between the original position and the welded position
Merge Vertex Tolerance Edges are coincident if both pairs of endpoint vertices are closer than this distance
Merge Search Tolerance Edges are considered as potentially the same if their midpoints are within this distance. Due to floating-point roundoff this should be larger than MergeVertexTolerance.
Merge Only Unique Pairs Only merge unambiguous pairs that have unique duplicate-edge matches

Classic › Editor › Advanced Operations

Transfer Weights